PDFsharp & MigraDoc Foundation

PDFsharp - A .NET library for processing PDF & MigraDoc Foundation - Creating documents on the fly
It is currently Fri Aug 12, 2022 12:51 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Feb 11, 2019 5:19 pm 
Offline
PDFsharp Guru
User avatar

Joined: Mon Oct 16, 2006 8:16 am
Posts: 3050
Location: Cologne, Germany
Hi all!

We have published NuGet packages without pre-release flag.

The packages have version 1.50.5147.

Link to our NuGet packages:
https://www.nuget.org/profiles/PDFsharp-Team

Note that we also published pre-release packages with version 1.51.*. Those looking for a stable version should get 1.50.5147 or a later version 1.50.*.

_________________
Regards
Thomas Hoevel
PDFsharp Team


Top
 Profile  
Reply with quote  
PostPosted: Thu May 05, 2022 12:10 pm 
Offline

Joined: Mon Aug 10, 2020 9:41 am
Posts: 1
Thomas Hoevel wrote:
Hi all!

We have published NuGet packages without pre-release flag.

The packages have version 1.50.5147.

Link to our NuGet packages:
https://www.nuget.org/profiles/PDFsharp-Team

Note that we also published pre-release packages with version 1.51.*. Those looking for a stable version should get 1.50.5147 or a later version 1.50.*.
These packages are now over three years old and there's some confusion as to whether they support .netstandard2.0 or not.

  • The first Project PdfSharp links to nuget ***here*** and this states ".NET Framework 2.0" at the very top - but when you add the package, it errors in a .net core project saying the package only supports .NETFramework versions 4.6.1, 4.6.2, 4.7, 4.7.1 and 4.7.2.
  • Similarly, the third Project PDFsharp-MigraDoc (very different combination of capitalisation BTW) links to nuget ***here*** which also states ".NET Framework 2.0" at the very top - but when you add the package, it also errors in a .net core project saying the package only supports .NETFramework versions 4.6.1, 4.6.2, 4.7, 4.7.1 and 4.7.2.
I've checked the beta versions and they are still also very much .NETFramework. Has there been development on stable .netstandard or .net (core/5.0+) versions?

Thanks,
BloodBaz


Top
 Profile  
Reply with quote  
PostPosted: Thu May 05, 2022 2:50 pm 
Offline
PDFsharp Expert
User avatar

Joined: Sat Mar 14, 2015 10:15 am
Posts: 734
Location: CCAA
BloodBaz wrote:
These packages are now over three years old and there's some confusion as to whether they support .netstandard2.0 or not.
Please note that .NET 2.0 is very old while .netstandard2.0 is rather new and probably newer than those packages.
Nobody ever claimed they would support .NET Core.

There are internal builds for .NET 6.0, but I have no information when they will be available as nuget packages or source code.

_________________
Best regards
Thomas
(Freelance Software Developer with several years of MigraDoc/PDFsharp experience)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Privacy Policy, Data Protection Declaration, Impressum
Powered by phpBB® Forum Software © phpBB Group